Priority: Low Component: setup.py, CI Type: Maintenance
Description
The project claims support for Python 3.6, but Python 3.6 reached end-of-life on December 23, 2021. Supporting EOL versions has security implications and limits use of newer Python features.
Current Configuration
setup.py: python_requires=">=3.6"
.github/workflows/run_tests.yml: Tests against 3.6-3.14
README.md: States "Python 3.6 or higher"
Problems
Python 3.6 receives no security updates
Prevents using features from 3.7+ (dataclasses, f-strings in older code, etc.)
Testing infrastructure for 3.6 is becoming harder to maintain
Python 3.14 doesn't exist yet (listed in CI)
Proposed Solution
Update minimum version to Python 3.8 (current oldest supported version):
3.7 EOL: June 2023
3.8 EOL: October 2024 (extended support)
3.9+: Currently supported
Benefits of requiring 3.8+:
Can use := walrus operator
Better typing support
importlib.metadata for version info
Still supports relatively old systems
Impact
Low - Most users are already on newer Python versions.
# Python 3.6 support should be dropped (EOL)
**Priority:** Low
**Component:** setup.py, CI
**Type:** Maintenance
## Description
The project claims support for Python 3.6, but Python 3.6 reached end-of-life on December 23, 2021. Supporting EOL versions has security implications and limits use of newer Python features.
## Current Configuration
- `setup.py`: `python_requires=">=3.6"`
- `.github/workflows/run_tests.yml`: Tests against 3.6-3.14
- `README.md`: States "Python 3.6 or higher"
## Problems
1. Python 3.6 receives no security updates
2. Prevents using features from 3.7+ (dataclasses, f-strings in older code, etc.)
3. Testing infrastructure for 3.6 is becoming harder to maintain
4. Python 3.14 doesn't exist yet (listed in CI)
## Proposed Solution
Update minimum version to Python 3.8 (current oldest supported version):
- 3.7 EOL: June 2023
- 3.8 EOL: October 2024 (extended support)
- 3.9+: Currently supported
Benefits of requiring 3.8+:
- Can use `:=` walrus operator
- Better typing support
- `importlib.metadata` for version info
- Still supports relatively old systems
## Impact
**Low** - Most users are already on newer Python versions.
Blocking a user prevents them from interacting with repositories, such as opening or commenting on pull requests or issues. Learn more about blocking a user.
Python 3.6 support should be dropped (EOL)
Priority: Low
Component: setup.py, CI
Type: Maintenance
Description
The project claims support for Python 3.6, but Python 3.6 reached end-of-life on December 23, 2021. Supporting EOL versions has security implications and limits use of newer Python features.
Current Configuration
setup.py:python_requires=">=3.6".github/workflows/run_tests.yml: Tests against 3.6-3.14README.md: States "Python 3.6 or higher"Problems
Proposed Solution
Update minimum version to Python 3.8 (current oldest supported version):
Benefits of requiring 3.8+:
:=walrus operatorimportlib.metadatafor version infoImpact
Low - Most users are already on newer Python versions.